黑群晖DS918+开启支持M.2 Nvme固态硬盘做缓存的补丁(已经支持DSM6.23版本)

其实,官方的白群DS918+ 这款产品是可以将两块Nvme SSD 做cache的,但是白群的DS3617xs和DS3615xs这两款产品不支持把Nvme SSD 当做cache,这是因为DS3617xs和DS3615xs的固件里并没有添加NVme的驱动;而DS918+的固件本身就有驱动,所以支持Nvme SSD。

但是,目前安装的黑群DS918+系统,哪怕你插入了Nvme SSD ,在存储空间管理员中,并不会像白群那样会显示“Nvme缓存设备”。如果到用ssh 命令行查看,又可以看到有Nvme SSD。主要的原因是DS918+的固件(以及其他群晖的支持Nvme的机型固件) 各自锁定了一个PCI 端口号作为Nvme设备的端口, 大家DIY的黑群主板必然和白裙不同,所以99%的可能性都是会DSM里看不到Nvme SSD。

Xpenolgoy论坛里最近有大牛已经靠Hack nvme 驱动解决了上述的问题。 具体步骤如下:

1、如果你的DS918系统是6.21版本到6.22版本之间的,下载这个Nvme驱动的脚本 libNVMEpatch.sh ( 点我下载 );

2、把下载的文件复制到黑群 /usr/local/etc/rc.d/ 目录下,并设置成可执行的权限(此步骤需要用root权限);

3、重启黑裙,然后就可以在你的黑群DS918+上使用Nvme SSD做cache了。

 

 

 


需要注意的是:

1、目前这个补丁只能用于黑群DS918+,黑群DS1019+未经测试不知道是否有效或者是否有不良反应;
2、原作者只保证对黑群DS918+的DSM-6.2-23739 版本有效(经测试,在黑群DS918+的6.2.2-24922 update4还是有效的),但是很可能下一次群晖DSM版本升级后,有可能会被系统文件覆盖,造成无效。如果你带着缓存升级之后,万一Nvme驱动又变成无效了,那么就会造成你的存储空间对应的存储盘缓存损毁,有可能存在存储空间变成不可用的风险。

 


2020年6月24日更新

如果你的DS918是6.23版本到6.23up3之间的版本,那么上面的补丁不能用了,需要用这个新的补丁。

具体步骤如下:

1、下载用于修改Nvme驱动的脚本 libsynonvme.so.1 ;( 点我下载

2、把下载的文件复制到黑群的 /usr/lib64 目录下,,并设置成可执行的权限(此步骤需要用root权限);

3、如果你已经打了上面的补丁,需要进 /usr/local/etc/rc.d 文件夹,把 libNVMEpatch.sh 删除(如果没有打过上面的补丁,此步骤可以跳过);

4、重启黑裙生效。

点赞
  1. ss说道:
    Google Chrome Windows 10
    命令 'rm -f -r "libNVMEpatch.sh"' 失败并返回1,错误消息 rm: cannot remove 'libNVMEpatch.sh': Permission denied。 winscp进去无法删除。。。找了下没有相关的教程删除
    1. ss说道:
      Google Chrome Windows 10
      rm /usr/local/etc/rc.d/libNVMEpatch.sh 举一反三找到了这个命令可以删除了 目前还是用不了单根nvme硬盘来做aio里的黑群晖,找pat文件提示无法格式化,应该还是没支持用nvme来装群辉
  2. ____Q__Q____说道:
    Google Chrome Windows 10
    如果带着补丁升级,升级了补丁失效会导致存储空间丢失,那怎么卸载补丁呢?先取消挂载ssd缓存,再去手动删除补丁文件再重启黑群吗?如果我只上一个nvme做只读缓存,那就算带着补丁升级应该也没影响吧?
    1. 博主说道:
      Google Chrome Windows 10
      建议先卸载SSD缓存再升级,否则升级会系统会报损毁。
      1. ____Q__Q____说道:
        Google Chrome Windows 10
        卸载缓存后还怎么卸载补丁呢?需要linux命令不?

发表评论